Решения
Демоверсия
Поддержка
Компания
 
 
 

Система удаленного банковского обслуживания. Руководство пользователя. Локальный клиент.

1 Статус документа

Настоящее Руководство является частью эксплуатационной документации на Систему удаленного банковского обслуживания на основе технологии Банк+Клиент СФТ ® (СУБО).
Данный документ соответствует версии программных компонент системы 7.0.1.

2 РМ локального клиента

2.1 Назначение

Рабочее место (РМ) Локального клиента предназначено для выполнения банковских операций по расчетным и текущим счетам клиентов банка на основании электронных документов.
Основные функции РМ Локального клиента:
• Формирование электронных документов, их просмотр, редактирование, печать;
• Поддержка электронно-цифровой подписи;
• Отправка документов в банк и получение документов из банка, используя каналы общего пользования, в том числе коммутируемые. Поддержка средств шифрования соединения;
• Экспорт/Импорт документов в систему учета Клиента;
• Протоколирование работы пользователей;
• Настройка параметров интерфейса.

2.2 Технология работы

РМ Локального клиента представляет собой win32-приложение, использующее базу данных для хранения и обработки документов. Связь с Банком для обмена документами осуществляется по протоколу HTTPS.

Для защиты информации, передаваемой через Интернет, от несанкционированного доступа производится шифрация всего трафика между РМ Локального клиента и веб-сервером по протоколу SSL. Хэширование пакетов в рамках SSL обеспечивает защиту передаваемых данных от несанкционированных изменений. SSL реализуется на основе продуктов Сигнал-КОМ: Inter-PRO Client на стороне Клиента и Inter-PRO Server в Банке, либо на основе продуктов Крипто-Про: КриптоПро CSP КриптоПро TLS, либо на основе стандартно поставляемого с Windows криптопровайдера Microsoft RSA.
Для защиты отдельных документов от несанкционированного изменения используется электронно-цифровая подпись (ЭЦП). Наложение и проверка подписи реализуется с помощью средств Сигнал-КОМ, или с помощью средств Крипто-Про, или с помощью Microsoft RSA, или с помощью библиотеки «Крипто-Экс» Crypto-C.
В используемых реализациях подсистемы безопасности обеспечивается полная поддержка отечественных алгоритмов шифрования и ЭЦП: ГОСТ 28147-89 для симметричного шифрования с длиной ключа 256 бит, ГОСТ Р 34.10-94 для ассимметричного шифрования и ГОСТ Р 34.11-94 или ГОСТ Р 34.10-2001 для хэширования данных.

2.3 Установка
2.3.1 Установка БД

Для установки необходимо воспользоваться средствами Microsoft SQL Server Enterprise Manager.
Создать соединение с SQL сервером
Создать в разделе Databases новую БД с именем CWSClient
Восстановить данные из архива, для этого выбрать из контекстного меню All Tasks/Restore Database, установить опцию Restore: “From device”, нажать кнопку Select Devices, нажать кнопку Add, выбрать файл, нажать кнопку Ok, выбрать вкладку Options, скорректировать пути файлов в колонке Move to physical file name, установить опцию Force restore over existing database, нажать кнопку Ok.

2.3.2 Организация сетевого рабочего места

Создать каталог на компьютере, например c:\CWS\RMLocalClient, скопировать в него файлы из каталога RMLocalClient дистрибутива
Запустить RMClient.exe
Нажать кнопку Конфигурация, выбрать вкладку Параметры соединения, настроить параметры соединения с БД Локального Клиента.
Заполнить поля Имя доступа базы данных, Пароль доступа базы данных, Имя доступа пользователя, нажать кнопку Соединиться, ввести пароль.

2.4 Начало работы (настройка)
2.4.1 Элементы пользовательского интерфейса

2.4.2 Настройка соединения с БД

АРМ предполагает возможность соединения с различными, не связанными друг с другом базами данных. Делается это путем создания различных объектов типа База Данных и Процесс. Объект Процесс в отличие от объекта База Данных в активном состоянии не имеет представлений документов, однако позволяет запустить выполнение выбранных задач по заданному расписанию (иными словами, создать автоматический обработчик).
Для создания объекта База Данных необходимо выбрать в меню Сервис /Служебные / Создание объекта База Данных.
Для создания объекта Процесс необходимо выбрать в меню Сервис /Служебные/ Создание объекта Процесс.

2.4.2.1 Настройка шаблонов соединений

Любой объект типа База Данных или Процесс может соединяться с БД через один из настроенных Шаблонов Соединений. Настройку списка шаблонов можно выполнить, нажав на кнопку […] рядом со выпадающим списком шаблонов документарной базы.

Для шаблона необходимо задать его имя, а также можно задать имя и пароль доступа к базе данных и имя и пароль доступа в систему (или и пароль Пользователя). Если Имя доступа пользователя и пароль пользователя заданы на страничке редактирования шаблона, то они не будут более запрашиваться при входе в систему.
После создания нового шаблона необходимо настроить его параметры (кнопка “Свойства”):

Сформировать строку соединения можно либо введя ее самостоятельно, либо нажав кнопку “Сформировать”.
Для корректного автоматического изменения структур баз данных необходимо для некоторых типов СУБД задать поле “Схема данных”. Для СУБД MS Access и Interbase это не требуется.
Далее необходимо перейти на вкладку Синтаксис и убедиться, что значение поля SQL-сервер соответствует реальному типу СУБД. Если это не так, то можно загрузить параметры особенностей синтаксиса запросов к СУБД из поставляемых файлов.

Далее, на вкладке Журнал необходимо отметить типы событий, которые будут регистрироваться в журнале событий:

2.4.2.2 Оповещения

Оповещения позволяют рассчитывать ключевые индикаторы состояния данных и выводить их в удобной форме. Кроме того, оповещения позволяют рассчитывать параметры только на одном из АРМ сетевой установки, а также назначать показывать рассчитанные параметры либо всем, либо только выбранным пользователям.
Расчет оповещения происходит согласно параметрам, определяемым в секции Alerts файла установок CWS.ini:
[Alerts]
AlertInitialDelay = 60000
Задает в миллисекундах задержку перед первым расчетом оповещений после старта приложения (по умолчанию – 1 минута)
[Alerts]
AlertGeneralDelay=60000
Задает в миллисекундах задержку между последующими расчетами (по умолчанию – 1 минута).
Оповещения настраиваются на вкладке Оповещения диалога настройки шаблонов:

В верхнем выкидном списке можно выбрать одно из значений:
• Без оповещений – Оповещения рассчитываться не будут
• Только при соединении с этой БД – Оповещения начинают рассчитываться только после соединения с БД
• Всегда – Расчет происходит даже если соединения БД не произошло.
Флажок Мигать при изменении значения приводит к миганию текста оповещения при изменении его значения при условии вывода оповещения в строку статуса.
Далее можно ввести сам текст оповещения, который состоит из наименований оповещений и последующего за ним текста запроса в базе данных.
Наименование Оповещения должно начинаться либо с одинарного символа #, либо с двойного - ##
# - Оповещение выводится в строку статуса основного окна Windows – Клиента. При нажатии мышкой на текст оповещения производится его повторный принудительный расчет вне расписания.
## - при изменении значения рассчитываемого параметра текст выводится в виде диалога сообщения.
Сам текст SQL запроса к Базе Данных должен возвращать единственное значение любого типа (не обязательно число). Кроме того, запрос может содержать строку &LOGIN& которая будет заменена на логин текущего Пользователя
Помимо прямого вода текста оповещений можно задать имя файла с текстом Оповещения. Файл должен находиться в каталоге LC АРМ.
Если не задан ни текст оповещений, ни файл с их текстом, то берется файл alerts.def каталога LC АРМ.
После соединения с Базой Данных становится доступна кнопка Пользователи, позволяющая задать назначение Пользователей конкретным Оповещениям:

При отсутствии хотя бы одного назначенного Пользователя, Оповещение будет показываться всем пользователям

2.4.2.3 Соединение с БД

Для этого необходимо выбрать либо объект База Данных, либо Процесс и выбрать в ниспадающих списках соответствующий шаблон соединения. При этом, как правило, шаблон соединения с базой системных объектов и базой документов один и тот же. Исключением является архивная база данных – для нее системная база – рабочая, а документарная – архивная.
После этого необходимо нажать кнопку Соединиться, ввести пароль.

2.4.3 Настройка параметров HTTP транспорта

Выбрать в панели ярлыков ярлык Система \ Обмен с банком, нажать кнопку Свойства, выбрать вкладку Параметры задачи
Ввести значения параметров:
HTTP-адрес СИДа – адрес asp-страницы – обработчика запросов (http://имя_сайта/cbs/webtrans.asp)
Имя конфигурации СИДа – название конфигурации на сервере (http)
Тип базы данных – задать «INTERBASE» для СУБД Interbase, «ISO» для СУБД Oracle с кодировкой ISO-8859-5, для других типов баз задается пустое значение (<пусто>)
Максимальный размер BLOB-поля (байт) – уменьшить для Sybase с ограничением размера BLOB-поля (2147483647)
Сертификат центра сертификации – имя файла сертификата центра сертификации или каталог расположения цепочки сертификатов центров сертификации, каталог должен завершаться символом «\» (например, D:\STEND\certif\client\SCOM\certca_3.pem; задается при использовании Сигнал-КОМ)
Список отозванных сертификатов – имя файла или каталог расположения списка(ов) отозванных сертификатов, если не используются, значение параметра можно оставить пустым (например, D:\STEND\certif\client\SCOM\crl_1.pem; задается при использовании Сигнал-КОМ)
Веб-логин – логин для прокси-сервера, требующего аутентификации (<пусто>)
Веб-пароль – пароль для прокси-сервера, требующего аутентификации (<пусто>)
Остальные параметры заполняются автоматически и обычно не требуют изменения:
Идентификатор сервера – идентификатор банка (INTERNET)
Собственный идентификатор – собственный идентификатор клиента (например, ORG_ООО "НИКА")
Режим сжатия – 0 – без сжатия, 1 – обычное сжатие, 2 – сжатие только сообщений больше размера транспортного пакета, 3 – быстрое сжатие, 4 – быстрое сжатие, сжимаются только сообщения больше размера транспортного пакета (1)
Префикс дополнительных собственных идентификаторов – при прямом подключении к базе СПБ задает префикс прочих собственных идентификаторов (<пусто>)
Тип базы данных СПБ – используется при прямом подключении к базе СПБ, задать «INTERBASE» для СУБД Interbase СПБ, «ISO» для СУБД Oracle с кодировкой ISO-8859-5 СПБ, для других типов баз задается пустое значение (<пусто>)
Строка соединения с БД СПБ – используется при прямом подключении к базе СПБ, при этом задается пустой адрес asp-страницы (<пусто>)
Максимальный размер BLOB-поля БД СПБ (байт) – используется при прямом подключении к базе СПБ, уменьшить для Sybase с ограничением размера BLOB-поля (2147483647)
Отладочный режим – список режимов отладки: задать «*» для полного режима отладки, «RST» для отладки SQL-запросов, «TRAN» для отладки алгоритма транспорта (<пусто>)
Отладочный файл – файл отладки (<пусто>)
Двоичный режим пересылки – тип кодировки данных (Да)
Размер HTTP-блока – размер блоков обмена в байтах, можно уменьшить при плохой линии (2048)
Максимальное количество документов в транспортном пакете – максимальное количество документов в пакете (32760)
Максимальный размер транспортного пакета (байт) – максимальный суммарный размер документов в пакете (786432)
Строка соединения с БД – строка соединения ADO в случае необходимости переопределить стандартную (<пусто>)
Таймаут соединения с БД (сек.) – время ожидания соединения с базой данных (300)
Таймаут операций с БД (сек.) – время выполнения запроса к базе данных (600)
Таймаут соединения с БД СПБ (сек.) – время ожидания соединения с базой данных СПБ при прямом подключении к ней (300)
Таймаут операций с БД СПБ (сек.) – время выполнения запроса к базе данных СПБ при прямом подключении к ней (600)
Не запускать приложение поддержки криптографии – задать Да для отключения автоматического запуска Inter-PRO Client при запуске HTTP-транспорта (Нет)
Нажать кнопку Ok, нажать кнопку Сохранить, выбрать пункт меню Документ \ Сохранить, нажать кнопку Сохранить.
Для работы HTTP-транспорта необходимо настроить Inter-PRO Client.

2.4.4 Удаленное обновление системы (обновление конфигурации и справочников, а также update/upgrade семейств, форм, отчетов и провайдеров)

Обновления пересылаются из Банка через HTTP транспорт, как и обычные документы и автоматически обрабатываются в РМ Локального Клиента. Чтобы принятые обновления вступили в действие, пользователь должен иметь право Инсталлятор или Администратор.

2.5 Работа с представлениями

Все документы показываются в виде списков, объединяющих документы по их виду. Эти списки называются Представления. Настройка состава документов и колонок Представлений описаны в главе: Настройка представлений.

Панель предосмотра позволяет просматривать содержимое одного или нескольких полей текущего документа.
Настройка представления осуществляется с помощью контекстного меню на заголовке любой колонки:

2.5.1 Сортировка по убыванию:

Позволяет задать способ сортировки для выбранной колонки.

2.5.2 Сортировка по возростанию:

Позволяет задать способ сортировки для выбранной колонки.
Также, для быстрой сортировки представления по определенной колонке необходимо нажать мышью на ее заголовке один раз для прямой сортировки и еще раз – для обратной.
Для сортировки по двум и более колонкам необходимо нажимать мышкой на их заголовки, удерживая кнопку Shift.

2.5.3 Группировать по колонке:

Группировка по одной или нескольким колонкам позволяет сгруппировать записи, имеющие одинаковые значения в данных колонках в группы, которые можно сортировать, а также схлопывать и раскрывать:

Колонки, участвующие в группировке, их порядок и сортировка показываются в верхней части представления - панели группировки. Кроме того, можно сгруппировать записи по колонке, перетащив ее на панель группировки.

2.5.4 Удалить колонку:

Удаление колонки приводит к ее скрытию для данного вида. Колонки можно впоследствии восстановить через диалог настройки колонок:

2.5.5 Расположение:

Позволяет задать способ выравнивания информации, выводимой в колонке

2.5.6 Оптимальная ширина:

Задает колонке минимальную ширину, достаточную для данных во всех записях.

2.5.7 Оптимальная ширина (Все колонки):

Задает всем колонкам минимальную ширину, достаточную для данных во всех записях.

2.5.8 Настройка:

В пунктах меню Настройка можно управлять показом/скрытием элементов представления:

2.5.9 Настройка. Панель группировки:

Показ Панели группировки. Подробнее – см. Группировать по колонке:

2.5.10 Настройка. Быстрая фильтрация:

Показ элементов быстрой фильтрации, позволяющих осуществлять фильтрацию по загруженным данным, определяемым основным фильтром без исполнения запроса к Базе Данных.
При включенном режиме для каждой колонки в заголовке выводится управляющий элемент (стрелка вниз):

Нажатие на эту стрелку приводит к показу списка возможных значений:

Выбор пункта “Задать” вызывает диалог более точной настройки Быстрой фильтрации по текущей колонке:

Если по одной или нескольким колонкам задана быстрая фильтрация, то соответствующая информация отображается внизу представления:

Нажатие на крест в описании быстрого фильтра приводит к его полному сбрасыванию

2.5.11 Настройка. Итог группы.

Показ итога группы – специальной панели в конце каждой группы колонок, предназначенной для показа агрегированной информации по группе.
Для выбора типа информации необходимо вызвать контекстное меню на панели итога группы под желаемой колонкой:

2.5.12 Настройка. Итог таблицы.

Итог таблицы аналогичен Итогу Группы, но показывается внизу всего представления и относится ко всем видимым записям представления.

2.5.13 Настройка. Список колонок.

Позволяет вывести список скрытых колонок:

Для перемещения колонок обратно в представление необходимо перетащить их с помощью мыши.

2.5.14 Панель инструмантов. Фильтрация.

Данная панель позволяет:
• Показать/скрыть панель поиска ,
• выбирать текущий вид представления,
• текущий фильтр,
• вызывать диалог настройки фильтров

2.5.14.1 Панель поиска.


Панель писка позволяет осуществить поиск значения в текущей колонке представления При этом можно пользоваться символами * (любое количество символов) и ? (один любой символ). При достижении конца представления произойдет запрос на продолжение поиска с начала представления.
Кроме поиска через Панель поиска также можно осуществлять поиск, находясь непосредственно в Представлении. Для этого необходимо выбрать ячейку нужной колонки и начать вводить первые символы искомого значения. При этом найденные символы будут помечаться черной заливкой:

Перемещаться между записями, отвечающими введенному критерию можно с помощью клавиш Ctrl+Enter (вниз на следующую) и Shift+Enter (вверх)

2.5.14.2 Текущий вид представления.

Для каждого представления можно создать несколько Видов. Каждый Вид содержит в себе полную информацию о способе показа данных, выбранных с помощью основного фильтра: состав и порядок колонок, группировка, наличие элементов представления, быструю фильтрацию, панель поиска и его настройки.
Для настройки списка видов текущего представления необходимо воспользоваться пунктом меню Настройка | Параметры отображения…

2.5.14.3 Текущий фильтр.

Фильтр представления определяет ограничения на информацию, запрашиваемую в Базе Данных. Правильная настройка и применение основного фильтра позволяет существенно уменьшить время запроса к базе данных. Для настройки фильтра необходимо из панели инструментов вызвать диалог настройки фильтров.
При необходимости можно настроить т.н. порог предупреждения о том, что в представлении слишком много записей – параметр MAX_ROW_COUNT секции [C] в cws.ini каталога LC ..
Кроме того, данный диалог показывается при входе в представление при условии:
• наличия нескольких уже определенных фильтров, если ни один из них не выбран
• отсутствия определенных фильтров
• (обязательно): в файле CWN.ini каталога LC определен параметр AskForFilter:
[GRID]
AskForFilter = 1

2.5.14.4 Диалог настройки фильтров.


Диалог позволяет управлять как составом фильтров, так и составом условий каждого фильтра.

2.6 Ввод документов
2.6.1 Ввод платежных поручений

Выбрать в панели ярлыков Документы \ ПП.
Выбрать пункт Создать \ Платежное поручение в меню Документ или нажать кнопку Создать \ Платежное поручение в панели инструментов.
Заполнить поля в появившемся окне. Поля размещены на двух страницах, переключаться между которыми можно, выбирая их в панели ярлыков или с помощью закладок, расположенных над страницей. Часть полей можно не вводить вручную, а выбрать из списка, для чего необходимо нажать кнопку , расположенную за полем.
Нажать кнопку OK в панели инструментов.

2.7 Подпись документов

Меню и панель инструментов Системы являются контекстно-зависимыми, т.е. зависят от текущего узла дерева объектов или элемента панели ярлыков. Например, при выборе ярлыка Исходящие \ Платежные Поручения в панели инструментов появляется кнопка Подпись документа, по которой можно подписать одно или несколько выбранных Платежных поручений.
Выбрать несколько документов из списка можно, удерживая кнопку Shift, если документы расположены подряд; или кнопку Ctrl, если документы расположены в разных частях списка.
При первом выполнении подписи документа или после смены ключей необходимо настроить параметры подписи, для чего в диалоге подписи выбрать уровень подписи и нажать кнопку Параметры.

При использовании безопасности на основе продуктов Сигнал-КОМ в диалоге параметров подписи задать Сертификат пользователя (для просмотра содержимого – пометьте галочку просматривать содержимое при выборе), Корневой каталог носителя СКЗИ Крипто-КОМ (имя каталога с символом «\» на конце), Сертификат центра сертификации (имя файла или каталог с цепочкой сертификатов центра сертификации, имя каталога – с символом каталога с символом «\» на конце), Список отозванных сертификатов (имя файла или каталога, каталог – с символом «\» на конце; если список отсутствует, параметр можно задать пустым).

Проверка подписи Банка производится автоматически при приеме документа, о настройке сертификата центра сертификации и списка отозванных сертификатов см. п. 2.4.3.
При необходимости подпись можно проверить вручную – для этого выделить нужный входящий документ (или документы), далее выбрать в меню Документ \ Действия \ Проверка подписи. При использовании Сигнал-КОМ при первом вызове (или после обновления данных файлов) в диалоге задать Сертификат центра сертификации (имя файла или каталога, каталог – с символом «\» на конце), Список отозванных сертификатов (имя файла или каталога, каталог – с символом «\» на конце; параметр может быть не задан, если список отозванных сертификатов отсутствует).
2.8 Отправка документов в банк Отправка документов в банк осуществляется задачей Обмен с банком, расположенной в разделе Система панели ярлыков. Запускается процесс кнопкой Выполнить.
Также можно воспользоваться пунктом меню Сервис / Обмен с Банком

После окончания обмена диалог обмена остается активным и в ним можно перейти на список полученных и отправленных документов:

2.9 Прием документов из банкка

Прием, как и отправка документов в банк осуществляется задачей Обмен с банком, см. п. Отправка документов в банк.

2.10 Акцептование

Акцептование на Локальном Клиенте становится доступным, если для данной Учетной Записи выбрана дополнительная конфигурация Акцептование. (см. Руководство Администратора)
При этом становятся доступными Вкладка “Акцептование” и представления в ней:
Акцептованные. Содержит все документы, по которым было принято решение вне зависимости от состава решения.
Для акцепта. Содержит документы, нуждающиеся в принятии решения
Для уведомления. Документы, не нуждающиеся в принятии по ним решения, но присланные для уведомления из дочерней организации.
Ответы. Документы-ответы по акцептованным документам.
Последовательность работы с этими представлениями следующая:
Первоначально все документы, присланные из СПБ и являющиеся документами дочерней организации (о настройке маршрутизации см. Руководство Администратора) попадают в представления Для акцепта или Для уведомления, в зависимости от настроек на СПБ.
По документам в представлении Для акцепта можно принять положительное или отрицательное решение, выбрав соответствующую команду в меню. В показываемом диалоге можно указать принимается ли документ или нет, а также ввести свой текст ответа, выбрав его из списка стандартных вариантов или введя самому:

После этого Документ, по которому было принято решение, становится доступен только из представления Акцептованные вне зависимости от типа принятого по нему решения.
Кроме того, в представлении Ответы становятся доступными Документы-ответы, которые можно Подписать и затем пометить к отправке в банк аналогично всем другим типам документов.
Так же в Документе-ответе можно просмотреть как собственно ответ, так и Оригинальный документ, по которому и было принято то или иное решение.
После проведения Обмена с банком Документы-ответы поступают в СПБ и обрабатываются там, согласно настройкам Маршрутизации.

2.11 Признаки документов

Дополнительно к состоянию документа, имеются признаки “Прочтен” и “Легкий Архив”. Они служат для более наглядного представления и фильтрации документов.
Визуальным признаком состояния Не Прочтен служит выделение жирным шрифтом (Bold).
Визуальным признаком состояния “Легкий Архив” служит выделение красным шрифтом. Прочтенный - (Normal) и Не Прочтенный (Bold).

Для изменения этих признаков используются команды меню Документ / Признак прочтения:
Пометить как прочтенный
Пометить как не прочтенный, а также пункт меню Документ / Легкий архив:
Поместить
Извлечь
Дополнительно, документ получает признак “Прочтен” при открытии в форме и получает признак “не прочтен”, если его состояние изменилось, например, после проведения обмена с банком.
Для эффективного использования признака “Легкий архив” существуют фильтры “Легкий архив”.
Для быстрой сортировки представления по определенной колонке необходимо нажать мышью на ее заголовке один раз для прямой сортировки и еще раз – для обратной.
Для сортировки по двум и более колонкам необходимо нажимать на их заголовки, удерживая кнопку Shift.
Кроме того, некоторые типы документов с состоянием “Не проведен” выделяются перечеркнутым шрифтом (strike)

2.11.1 Шаблоны

Также имеется возможность присвоить документу тип состояния “Шаблон”. При этом документ подсвечивается синим цветом. Создается шаблон с помощью команды “Создать Шаблон”, выполняемой над Документом, по которому необходимо его создать.
В дальнейшем к шаблону можно применять команду “Создать по образцу”, облегчив тем самым себе заполнение полей нового Документа, поскольку часть полей может быть предварительно заполнена еще в шаблоне.

2.12 Печать документов

Для печати документа, например, ПП, необходимо стать на него в списке ПП (список ПП открывается, если выбрать соответствующий ярлык в разделе Документы панели ярлыков) и выбрать пункт меню Печать в разделе Документ или нажать кнопку Печать в панели инструментов.

Далее, выбрать принтер из списка и нажать кнопку Печатать.
Для печати в файл необходимо выбрать в списке принтеров пункт “Печатать в файл”. При этом будет производиться вывод в файл формата WMF (Windows Meta File)

2.13 Журнилирование и аудит

В системе ведется Журнал событий, в который записываются все, существенные с точки зрения системы, действия. Например, такие как: создание, редактирование, удаление документов, подпись, результаты сеансов связи с Банком.
Ведение журнала событий позволяет, в случае необходимости, восстановить ход событий и установить причину, приведшую к ошибочному результату.
Для просмотра журнала событий необходимо войти в дерево объектов и выбрать узел БД \ Users \ <пользователь> \ Системные \ Журнал событий.

2.14 Настройка рабочего места
2.14.1 Настройка представлений

Настройка представлений может осуществляется как для всех пользователей программы так и для каждого пользователя индивидуально. Для настройки общих представлений необходимо зайти в узел дерева объектов БД \ Общая конфигурация \ Список полей \ Все поля. Для настройки индивидуальных представлений необходимо войти в узел БД \ Users \ <имя пользователя> \ Список полей \ Все поля и выбрать в меню Документ \ Представление.

Поле Полное имя задает имя и место представления в дереве объектов. Поле Краткое имя задает вид представления в панели ярлыков.
Для того, чтобы вывести ссылку на представление в панель ярлыков, нужно выбрать в списке поле Краткое имя, в поле Заголовок ввести имя ярлыка, в поле Группа ввести имя раздела панели ярлыков, выбрать Для всех объектов формы и выбрать картинку для ярлыка, нажав кнопку Картинка.
Для настройки типов документов, которые будут показываться в представлении, и для настройки условий фильтрации необходимо перейти на закладку Фильтр. Для настройки типов документов выбрать в списке строчку Типы документов, в Типе фильтрации выбрать Конкретные документы, нажать кнопку Условие и отметить нужные типы.
Для настройки колонок представления необходимо перейти в закладку Колонки и заполнить список. Для каждой колонки можно задать заголовок, способ выравнивания, ширину и связь с полем данных документа. Для автоматического заполнения списка колонок полями документа, выбранного в закладке Фильтр, нажмите кнопку По умолчанию.
Для сохранения представления необходимо нажать кнопку Сохранить и выбрать пункт Сохранить в меню Документ. Если было изменено положение представления в панели ярлыков, изменения вступят в силу только после повторного соединения с БД или выхода из программы.

2.15 Резервирование и восстановление (включая общие и пользовательские конфигурационные параметры)

Резервирование включает в себя создание копий исполняемых файлов Системы, конфигурационных файлов и резервирование базы данных.
Резервирование базы данных осуществляется средствами СУБД. Для Microsoft SQL Server можно воспользоваться средствами автоматического сохранения копий БД (backup), которые настраиваются из Microsoft SQL Server Enterprise Manager.
Сохранение копий исполняемых и конфигурационных файлов системы на внешний носитель (CD ROM) или на сетевой диск следует проводить после каждого обновления версии исполняемых файлов и после существенных изменений конфигурационных файлов. Конфигурационные файлы хранятся в директории LC и содержат настройки соединения с БД, настройки элементов пользовательского интерфейса программы, такие как размеры окон, состав панели инструментов и т.п.
Копировать следует весь каталог с программой, например, командой OS
xcopy c:\CWS\RMLocalClient h:\CWS\CWS\RMLocalClient /e
Для восстановления исполняемых и конфигурационных файлов необходимо просто скопировать из архива весь каталог с программой:
xcopy h:\CWS\RMLocalClient c:\CWS\CWS\RMLocalClient /e
Для восстановления базы данных необходимо воспользоваться командой Restore Database Microsoft SQL Server Enterprise Manager.
2.16 Архивация старых документов
Для уменьшения размера рабочей БД и ускорения работы необходимо регулярно архивировать старые документы в архивную БД.
Используемые настройки задачи архивация документов(задача Обслуживание БД–Архивация документов):
1) Строка соединения для архивной базы данных
2) Имя пользователя соединения для архивной базы данных
3) Пароль пользователя соединения для архивной базы данных
4) Глубина архивации в днях – кол-во дней, не подлежащих архивированию. По умолчанию = 1
5) Шаг архивации в днях – кол-во дней, которые будут архивироваться за один шаг архивации. По умолчанию = 1.
6) Мах размер архивной БД – размер БД (кол-во записей), по достижении которого требуется архивировать в новую архивную БД.
7) Только удаление – если “Да”, то данные не архивируются в архивную БД, а удаляются, в этом случае параметры 1)-3) и 6) можно не указывать.
8) Схема данных(только для oracle) - схема для архивной БД, используется и заполняется только для oracle
9) Глубина архивации в днях (для выписок и проводок) - кол-во дней, не подлежащих архивированию (для выписок и проводок). По умолчанию = 0,в этом случае совпадает с параметром №4.
10) Время архивирования (в минутах): время, в течение которого выполняется архивация. По умолчанию = 0(без ограничения по времени)
Если параметр 1) не заполнен или архивная БД достигла max размера, отображается диалог выбора архивной БД:

Кнопка “Добавить” – формирование и добавление строки подключения к архивной БД
Кнопка “Удалить” – удаление записи об архивной БД из таблицы архивных БД.
После добавления архивной БД можно продолжить архивирование.
Список документов, подлежащих архивированию, смотрите в приложении 3.1.

2.17 Сжатие БД

Для уменьшения размера и увеличения скорости работы БД Interbase и Microsoft Access необходимо регулярно (не меньше 1 раза в месяц) проводить сжатие БД.
Для выполнения сжатия БД необходимо запустить задачу “Обслуживание БД–Сжатие БД”

2.18 Резервирование БД Interbase(Firebird)

Для того чтобы обеспечить возможность восстановить данные в случае сбоя в работе компьютера или БД, рекомендуется сохранять резервные копии БД.
Для БД Firebird(Interbase) это делается при помощи задачи Резервирование/Восстановление БД(Interbase)

Рекомендуемые значения для резервирования БД уже установлены по умолчанию.
BackUp-файл – файл в который будет сохранена резервная копия БД.
После резервирования можно произвести восстановление из резервного файла при установленном действии – “Восстановление”. Все рекомендуемые параметры установлены по умолчанию.
Цикл резервирование-восстановление аналогичен операции сжатия БД.

2.19 Ключи и сертификаты

Генерация (перегенерация) ключей и запросов на сертификат производится штатными средствами Сигнал-КОМ (Inter-PRO Client, Admin-PKI) или утилитами SrvCert.exe (Крипто-Про, Microsoft RSA), CryptoC.exe (при ЭЦП Крипто-Экс Crypto-C). По запросам на сертификат Банк выдает сертификаты пользователей, а также сертификат центра сертификации (или цепочку сертификатов ЦС), также периодически (например, при компрометации сертификата Банка) может высылать список отозванных сертификатов. В системе используются:
• секретный ключ и сертификат Транспорта Клиента – используются при аутентификации Клиента на Сервере Интернет Доступа Банка и шифрации трафика в момент вызова HTTP-транспорта, настраиваются в параметрах SSL-контекста Сигнал-КОМ Inter-PRO Client или выбираются автоматически по параметрам сертификатов транспорта по в хранилище сертификатов для Крипто-Про и Microsoft RSA, могут совпадать с секретным ключом и сертификатом Пользователя (см. ниже);
• секретный ключ и сертификат Пользователя – используются при подписи Пользователя, настраиваются в параметрах для Сигнал-КОМ (или выбираются автоматически по параметрам сертификатов пользователя по в хранилище сертификатов для Крипто-Про и Microsoft RSA) – см. п. 2.7;
• сертификат (цепочка сертификатов) центра сертификации и список отозванных сертификатов – используются в вышеперечисленных операциях, а также при проверке подписи Банка, настройку см. в пп. 2.4.3, 2.7.
После получения сертификатов из банка необходимо выполнить следующие настройки :
Настройка InterPRO
Запустить InterPRO
Щелкнуть правой кнопкой мыши на иконку и перейти в меню «открыть» .
В закладке «дополнительно» открыть «Правила защиты»
Выбрать запись со своим ресурсом .
Отредактировать поля «Каталог ключевого носителя СКЗИ» и «Файл сертификата» (!Файл сертификата центра сертификации – не изменять ! )
Настройка Банк-Клиент
Запустить систему Банк-Клиент , выполнить соединение с БД пользователем, отличным от ADMIN .
На панели слева выбрать любое из представлений , например, «Исходящие документы», а в них – «Рублевые документы / Платёжные поручения»
После открытия представления соответствующего представления , перейти в закладку из верхнего меню «Настройка»–«Параметры задач»
В открывшемся окне из списка последовательно выбрать задачи «Обмен с банком» , «Подписать», «Проверка подписи» .
Выполнить проверку и при необходимости настройку задачи – кнопка «Параметры» .
Для задачи «обмен с банком» проверить настройку параметров :
• HTTP-адрес СИДа ;
• Имя конфигурации СИДа ;
• Сертификат центра сертификации ;
• Собственный идентификатор .
Для задачи «Подписать» выполнить настройку для каждого логина пользователя , предварительно скопировав полученный из Банка сертификат ( файл типа .pem ) на соответствующий носитель .

Для задачи «Проверка подписи» настроить параметр «сертификат центра сертификации» .

5. По окончании настроек нажать кнопку «Сохранить»/»Выбор» .

3 Приложение

3.1 Список документов, подлежащих архивированию

На Клиенте, архивируем документы, дата которых больше чем глубина архивации (глубина архивации – настраиваемый параметр):
Архивируем типы документов, помеченные как Архивируемые
Все документы из легкого архива
Исходящие документы, прошедшие обработку в банке (состояния 33 и 34 и 25)
+ Все ДСФ в состоянии 32
Все входящие
Локальные обновления(OH_KIND = 1)
Копии на обновления, оригиналы которых подлежат архивированию
Записи из журнала системных событий(eventlog) относящиеся к документам или ошибкам архивируем, остальные удаляем

Более подробную информацию о системе Банк+Клиент СФТ можно получить по тф. +7 (495) 626-26-22 или по электронной почте sales@sftcomp.ru.

 
 
Разработка:
SFT Company © 2007-2012